Symptoms

Disclaimer: Este artigo é uma tradução do Sample configuration of EtherChannel / Link Aggregation Control Protocol (LACP) with ESXi/ESX and Cisco/HP switches (1004048). Como os artigos são traduzidos em uma base de melhor esforço, o conteúdo pode tornar-se desatualizado. Para obter o conteúdo mais recente, consulte o artigo em Inglês.

 Purpose

Este artigo fornece informações sobre os conceitos, as limitações e alguns exemplos de configuração de agregação de links, Agrupamento de NIC, LACP (Protocolo de Controle de Agregação de Links) e conectividade EtherChannel entre o ESXi/ESX e os Switches de Rede Físicos, particularmente para switches Cisco e HP.

 Resolution


Observação: há uma série de requisitos que devem ser considerados antes da implementação de qualquer forma de agregação de links. Para obter informações adicionadas/relacionadas sobre esses requisitos, consulte Host requirements for link aggregation for ESXi and ESX (1001938).

Conceitos de agregação de links:
  • EtherChannel: Este é um método de agregação de link (port trunking) usado para fornecer tolerância a falhas e links de alta velocidade entre switches, roteadores e servidores agrupando de dois a oito links Ethernet físicos para criar um link Ethernet lógico com links failover adicionais. Para obter mais informações sobre o EtherChannel Cisco, consulte EtherChannel Introduction da Cisco.
  • LACP ou IEEE 802.3ad: O Protocolo de Controle de Agregação de Link (LACP) está incluído na especificação IEEE como um método de controlar a integração de diversas portas físicas juntas para formar um único canal lógico. O LACP permite que um dispositivo de rede negocie uma integração automática de links enviando pacotes LACP ao par (dispositivo diretamente conectado que também implementa o LACP). Para obter mais informações sobre o LACP, consulte o informe sobre o Protocolo de Controle de Agregação de Link da Cisco.

    Observação: o LACP apenas tem suporte no vSphere 5.1 e 5.5 com o uso de vSphere Distributed Switches (VDS) ou do Cisco Nexus 1000v.

  • EtherChannel e 802.ad: Os padrões EtherChannel e IEEE 802.3ad são bastante semelhantes e cumprem o mesmo objetivo. Há algumas diferenças entre os dois, além do fato de o EtherChannel ser propriedade da Cisco e de o 802.3ad ser um padrão aberto.
  • Para obter mais informações sobre a implementação do EtherChannel, consulte o artigo da Cisco Understanding EtherChannel Load Balancing and Redundancy on Catalyst Switches.
Cenários com suporte para o EtherChannel:
  • Um IP para muitas conexões de IP. (Host A estabelecendo duas sessões de conexão com os Hosts B e C)
  • Muitos IPs para muitas conexões de IP. (Várias sessões de conexão dos Hosts A e B com os Hosts C, D e etc.)

    Observação: não há suporte para conexões de um IP com um IP em vários NICs. (Uma sessão de conexão do Host A ao Host B usa somente uma NIC).

  • Compatível com todos os modos de configuração de VLAN do ESXi/ESX: VST, EST e VGT. Para obter mais informações sobre estes modelos, consulte VLAN Configuration on Virtual Switch, Physical Switch, and Virtual Machines (1003806).
  • Configuração Cisco compatível: Modo EtherChannel LIGADO – (Habilitar apenas o EtherChannel)
  • Configuração HP compatível: Modo Trunk
  • Algoritmos de agregação de switch compatíveis: IP-SRC-DST (abreviação de IP-Source-Destination)
  • Modo compatível de equipe da NIC de switches virtuais : IP HASH. No entanto, consulte a seguinte observação:

    Observação: o suporte para LACP no vSphere Distributed Switch 5.1 somente é compatível com balanceamento de carga e IP hash. No vSphere Distributed Switch 5.5, há suporte para todos os algoritmos de balanceamento de carga do LACP:

    • Não utilize beacon probing com balanceamento de cargas IP HASH.
    • Não configure link em espera ou não utilizado com balanceamento de carga IP HASH.
    • O vSphere Distributed Switch 5.1 apenas oferece suporte a um EtherChannel para cada vNetwork Distributed Switch (vDS). No entanto, o vSphere Distributed Switch 5.5 oferece suporte a vários LAGs.

  • Modelos anteriores de switches Cisco podem ter MAC-SRC-DST definido por padrão, podendo exigir configuração adicional. Para obter mais informações, consulte o artigo da Cisco Understanding EtherChannel Load Balancing and Redundancy on Catalyst Switches.

Este é um exemplo de configuração do Cisco EtherChannel:

interface Port-channel1
switchport
switchport access vlan 100
switchport mode access
no ip address
!
interface GigabitEthernet1/1
switchport
switchport access vlan 100
switchport mode access
no ip address
channel-group 1 mode on
!


Topologia e configuração de amostras de switches ESX Server e Cisco:

Execute este comando para verificar a configuração do modo de balanceamento de carga do EtherChannel:

Switch# show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-dst-ip
mpls label-ip
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination IP address
IPv6: Source XOR Destination IP address
MPLS: Label or IP

Switch# show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+--------------------------
1 Po1(SU) - Gi1/15(P) Gi1/16(P)
2 Po2(SU) - Gi1/1(P) Gi1/2(P)

Switch# show etherchannel protocol
Channel-group listing:
-----------------------
Group: 1
----------
Protocol: - (Mode ON)
Group: 2
----------
Protocol: - (Mode ON)


Exemplo de configuração de switch HP

Esta configuração é específica para switches HP:
  • Switches HP oferecem suporte a apenas dois modos de LACP:
    • ATIVO
    • PASSIVO

      Observação: o LACP apenas tem suporte no vSphere 5.1 e 5.5 com vSphere Distributed Switches e no Cisco Nexus 1000V.

  • Defina o modo de porta do switch HP como TRUNK para realizar a agregação de links estáticos com o ESXi/ESX.
  • O Modo TRUNK das portas de switches HP é o único método de agregação compatível com o modo de agrupamento de NIC IP hash do ESXi/ESX.

Para configurar um canal de porta estático em um switch HP usando as portas 10, 11, 12 e 13, execute este comando:

conf
trunk 10-13 Trk1 Trunk


Para verificar seu port-channel, execute este comando:

ProCurve# show trunk
Load Balancing
Port | Name Type | Group Type
---- + --------- + ----- -----
10 | 100/1000T | Trk1 Trunk
11 | 100/1000T | Trk1 Trunk
12 | 100/1000T | Trk1 Trunk
13 | 100/1000T | Trk1 Trunk


Configurando o balanceamento de carga no vSphere/VMware Infrastructure Client

Para configurar as propriedades do vSwitch para balanceamento de carga:
  1. Clique no host ESXi/ESX.
  2. Clique na guia Configuration.
  3. Clique no link Networking.
  4. Clique em Properties.
  5. Clique no switch virtual na guia Ports e clique em Edit.
  6. Clique na guia NIC Teaming.
  7. No menu suspenso Load Balancing, selecione Route based on ip hash. No entanto, consulte a observação abaixo.
  8. Verifique se existem dois ou mais adaptadores de rede listados em Active Adapters.

Observação: o suporte para LACP no vSphere Distributed Switch 5.1 somente é compatível com balanceamento de carga e IP hash. No vSphere Distributed Switch 5.5, há suporte para todos os algoritmos de balanceamento de carga do LACP:
  • Convém definir o agrupamento de NIC como IP HASH tanto no vSwitch quanto no grupo de portas incluído que contém a porta de gerenciamento do kernel. Consulte a seção Informações Adicionais, Para obter mais informações sobre o agrupamento de NIC com o EtherChannel.
  • Não utilize beacon probing com balanceamento de cargas IP HASH.
  • Não configure link em espera ou não utilizado com balanceamento de carga IP HASH.
  • O vSphere Distributed Switch 5.1 apenas oferece suporte a um EtherChannel para cada vNetwork Distributed Switch (vDS). No entanto, o vSphere Distributed Switch 5.5 oferece suporte a vários LAGs.
  • O ESX/ESXi em execução em um sistema de blade não exigirá o balanceamento de carga IP Hash se um EtherChannel existir entre o chassis do blade e switch upstream. Isso apenas será necessário se um EtherChannel existir entre o blade e o switch do chassis interno, ou se o blade estiver operando em um modo de passagem de rede com um EtherChannel para o switch upstream. Para obter mais informações sobre esses vários cenários, entre em contato com o fornecedor de hardware do blade.
 Related Information
Para obter mais informações sobre o agrupamento de NIC com o EtherChannel, consulte NIC teaming using EtherChannel leads to intermittent network connectivity in ESXi (1022751).

O LACP tem suporte no vSphere ESXi 5.1 e 5.5 apenas em VMware vDistributed Switches. Para obter mais informações, consulte Enabling or disabling LACP on an Uplink Port Group using the vSphere Web Client (2034277) e o whitepaper What's New in VMware vSphere 5.1 - Networking.

Removendo uma configuração EtherChannel de um host ESX/ESXi em execução

Para remover o EtherChannel, deve haver apenas um adaptador de rede ativo no vSwitch/dvSwitch. Certifique-se de que os outros NICs host na configuração EtherChannel estejam desconectados (Link Inativo). Escolha uma das opções a seguir:

Com uma única placa de rede on-line, você pode remover a configuração de canal de porta do switch de rede físico e alterar as configurações de agrupamento de rede no vSwitch/dvSwitch de IP HASH para portID. Para obter mais informações sobre o recurso de agrupamento, consulte NIC teaming in ESXi and ESX (1004088).

Sample configuration of EtherChannel / Link Aggregation Control Protocol (LACP) with ESXi/ESX and Cisco/HP switches